[dpdk-dev] [PATCH] log:Change magic number on RTE_LOG_LEVEL to a define

Thomas Monjalon thomas.monjalon at 6wind.com
Sun Aug 2 22:44:39 CEST 2015


2015-08-02 19:10, Wiles, Keith:
> On 8/2/15, 12:15 PM, "Thomas Monjalon" <thomas.monjalon at 6wind.com> wrote:
> >2015-06-06 19:04, Keith Wiles:
> >> +# Log level use: RTE_LOG_XXX
> >> +#   XXX = NOOP, EMERG, ALERT, CRIT, ERR, WARNING, NOTICE, INFO or DEBUG
> >> +#   Look in rte_log.h for others if any.
> >> +#
> >
> >I think this comment is useless.
> 
> I do not think the comment is useless as some may not understand what
> values the Log level can be set too in the future. Not commenting the
> change would be a problem IMO. This is also why the line was moved.

It is already documented in the API doc.
I agree having some comments in the config files would be convenient but:
	- this one is 3 lines long
	- currently comments are only used to separate sections
Maybe you can do a oneline:
	# Minimum log level compiled: DEBUG, INFO, NOTICE, WARNING or ERR
I think it is important to tell it is a minimum log level, i.e. compiled logs.
And probably it is not needed to suggest a minimum level higher than ERR.

> >> +enum {
> >> +	RTE_LOG_NOOP = 0,   /**< Noop not used (zero entry)        */
> >
> >NOOP is useless: EMERG may be = 1
> 
> Does it really matter if I used RTE_LOG_NOOP, just to make sure someone
> did not try to use zero here. Instead of setting the RTE_LOG_EMERG=1, I
> can change it to be the way you suggest, but I think it does not hurt
> anything does it?

We avoid adding code without real use which could cause confusion.

> >> +	RTE_LOG_EMERG,      /**< System is unusable.               */
> >> +	RTE_LOG_ALERT,      /**< Action must be taken immediately. */
> >> +	RTE_LOG_CRIT,       /**< Critical conditions.              */
> >> +	RTE_LOG_ERR,        /**< Error conditions.                 */
> >> +	RTE_LOG_WARNING,    /**< Warning conditions.               */
> >> +	RTE_LOG_NOTICE,     /**< Normal but significant condition. */
> >> +	RTE_LOG_INFO,       /**< Informational.                    */
> >> +	RTE_LOG_DEBUG       /**< Debug-level messages.             */
> >> +};
> >
> >What is the benefit of this change?
> 
> The change is to use a enum in place of using magic numbers, plus you get
> the benefit of seeing the enum name in the debugger instead of a number.
> It makes the code more readable IMHO.

OK so a comment in the commit message could give the debugger justification.



More information about the dev mailing list