[dpdk-dev] [PATCH v9 02/14] eal_pci: Add flag to hold kernel driver type

Thomas Monjalon thomas.monjalon at 6wind.com
Thu Feb 19 12:17:53 CET 2015


> @@ -152,6 +159,7 @@ struct rte_pci_device {
>  	uint16_t max_vfs;                       /**< sriov enable if not zero */
>  	int numa_node;                          /**< NUMA node connection */
>  	struct rte_devargs *devargs;            /**< Device user arguments */
> +	enum rte_pt_driver pt_driver;		/**< Driver of passthrough */
[...]
> +static int
> +pci_get_kernel_driver_by_path(const char *filename, char *dri_name)

I think "kernel driver" is a good name. Why not using this name in the
pci_device struct to be more consistent?

Thanks


More information about the dev mailing list