[dpdk-dev] [PATCH 1/3] librte_ether: add RTE_ETH_FDIR_OTHER for flow director behavior

Bruce Richardson bruce.richardson at intel.com
Tue Sep 29 16:38:23 CEST 2015


On Tue, Sep 29, 2015 at 03:26:38PM +0100, Andrey Chilikin wrote:
> Add new flow director behavior RTE_ETH_FDIR_OTHER to assign a queue by other filters
> 
> Signed-off-by: Andrey Chilikin <andrey.chilikin at intel.com>
> ---
>  lib/librte_ether/rte_eth_ctrl.h |    1 +
>  1 files changed, 1 insertions(+), 0 deletions(-)
> 
> diff --git a/lib/librte_ether/rte_eth_ctrl.h b/lib/librte_ether/rte_eth_ctrl.h
> index 26b7b33..3acf501 100644
> --- a/lib/librte_ether/rte_eth_ctrl.h
> +++ b/lib/librte_ether/rte_eth_ctrl.h
> @@ -417,6 +417,7 @@ struct rte_eth_fdir_input {
>  enum rte_eth_fdir_behavior {
>  	RTE_ETH_FDIR_ACCEPT = 0,
>  	RTE_ETH_FDIR_REJECT,
> +	RTE_ETH_FDIR_OTHER,
>  };
>  
>  /**
> -- 
> 1.7.4.1
> 
Is "OTHER" meant to be a "NOOP" or a generic hold-all for a set of other possible
behaviours. From the description, I would assume NOOP - in which case would
RTE_ETH_FDIR_NOOP not be a better name?

/Bruce


More information about the dev mailing list