[dpdk-dev] [PATCH v5 29/29] net/i40e: set/clear VF stats from PF

Iremonger, Bernard bernard.iremonger at intel.com
Thu Dec 22 17:38:45 CET 2016



> -----Original Message-----
> From: Lu, Wenzhuo
> Sent: Wednesday, December 21, 2016 12:56 AM
> To: Iremonger, Bernard <bernard.iremonger at intel.com>; Yigit, Ferruh
> <ferruh.yigit at intel.com>; dev at dpdk.org
> Cc: Wu, Jingjing <jingjing.wu at intel.com>; Zhang, Helin
> <helin.zhang at intel.com>; Zhang, Qi Z <qi.z.zhang at intel.com>; Chen, Jing D
> <jing.d.chen at intel.com>
> Subject: RE: [dpdk-dev] [PATCH v5 29/29] net/i40e: set/clear VF stats from PF
> 
> Hi all,
> 
> 
> > -----Original Message-----
> > From: Iremonger, Bernard
> > Sent: Tuesday, December 20, 2016 9:40 PM
> > To: Yigit, Ferruh; dev at dpdk.org
> > Cc: Wu, Jingjing; Zhang, Helin; Zhang, Qi Z; Lu, Wenzhuo; Chen, Jing D
> > Subject: RE: [dpdk-dev] [PATCH v5 29/29] net/i40e: set/clear VF stats
> > from PF
> >
> > Hi Ferruh,
> >
> > > -----Original Message-----
> > > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Ferruh Yigit
> > > Sent: Tuesday, December 20, 2016 1:25 PM
> > > To: dev at dpdk.org
> > > Cc: Wu, Jingjing <jingjing.wu at intel.com>; Zhang, Helin
> > > <helin.zhang at intel.com>; Zhang, Qi Z <qi.z.zhang at intel.com>; Lu,
> > > Wenzhuo <wenzhuo.lu at intel.com>; Chen, Jing D
> <jing.d.chen at intel.com>
> > > Subject: Re: [dpdk-dev] [PATCH v5 29/29] net/i40e: set/clear VF
> > > stats from PF
> > >
> > > On 12/16/2016 7:02 PM, Ferruh Yigit wrote:
> > > > From: Qi Zhang <qi.z.zhang at intel.com>
> > > >
> > > > This patch add support to get/clear VF statistics from PF side.
> > > > Two APIs are added:
> > > > rte_pmd_i40e_get_vf_stats.
> > > > rte_pmd_i40e_reset_vf_stats.
> > > >
> > > > Signed-off-by: Qi Zhang <qi.z.zhang at intel.com>
> > > > ---
> > >
> > > <...>
> > >
> > > > diff --git a/drivers/net/i40e/rte_pmd_i40e_version.map
> > > > b/drivers/net/i40e/rte_pmd_i40e_version.map
> > > > index 8ac1bc8..7a5d211 100644
> > > > --- a/drivers/net/i40e/rte_pmd_i40e_version.map
> > > > +++ b/drivers/net/i40e/rte_pmd_i40e_version.map
> > > > @@ -6,7 +6,9 @@ DPDK_2.0 {
> > > >  DPDK_17.02 {
> > > >  	global:
> > > >
> > > > +	rte_pmd_i40e_get_vf_stats;
> > > >  	rte_pmd_i40e_ping_vfs;
> > > > +	rte_pmd_i40e_reset_vf_stats;
> > > >  	rte_pmd_i40e_set_tx_loopback;
> > > >  	rte_pmd_i40e_set_vf_broadcast;
> > > >  	rte_pmd_i40e_set_vf_mac_addr;
> > >
> > > Hi Wenzhuo, Mark,
> > >
> > > I think this is the list of all APIs added with this patchset.
> > >
> > > Just a question, what do you think following a logic in API naming as:
> > > <name_space>_<object>_<action> ?
> > >
> > > So API names become:
> > > rte_pmd_i40e_tx_loopback_set;
> > > rte_pmd_i40e_vf_broadcast_set;
> > > rte_pmd_i40e_vf_mac_addr_set;
> > > rte_pmd_i40e_vfs_ping;
> > > rte_pmd_i40e_vf_stats_get;
> > > rte_pmd_i40e_vf_stats_reset;
> > >
> > >
> > > After above rename, rte_pmd_i40e_tx_loopback_set() is not giving a
> > > hint that this is something related to the PF controlling VF,
> > > perhaps we can rename the API ?
> > >
> > > Also rte_pmd_i40e_vfs_ping() can become rte_pmd_i40e_vf_ping_all()
> > > to be more consistent about _vf_ usage.
> > >
> > > Overall, they can be something like:
> > > rte_pmd_i40e_vf_broadcast_set;
> > > rte_pmd_i40e_vf_mac_addr_set;
> > > rte_pmd_i40e_vf_ping_all;
> > > rte_pmd_i40e_vf_stats_get;
> > > rte_pmd_i40e_vf_stats_reset;
> > > rte_pmd_i40e_vf_tx_loopback_set;
> > >
> > > What do you think?
> > >
> >
> > I think the naming should be consistent with what has already been
> > implemented for the ixgbe PMD.
> > 	rte_pmd_ixgbe_set_all_queues_drop_en;
> > 	rte_pmd_ixgbe_set_tx_loopback;
> > 	rte_pmd_ixgbe_set_vf_mac_addr;
> > 	rte_pmd_ixgbe_set_vf_mac_anti_spoof;
> > 	rte_pmd_ixgbe_set_vf_split_drop_en;
> > 	rte_pmd_ixgbe_set_vf_vlan_anti_spoof;
> > 	rte_pmd_ixgbe_set_vf_vlan_insert;
> > 	rte_pmd_ixgbe_set_vf_vlan_stripq;
> >
> > 	rte_pmd_ixgbe_set_vf_rate_limit;
> > 	rte_pmd_ixgbe_set_vf_rx;
> > 	rte_pmd_ixgbe_set_vf_rxmode;
> > 	rte_pmd_ixgbe_set_vf_tx;
> > 	rte_pmd_ixgbe_set_vf_vlan_filter;
> So, seems better to use the current names. Rework both ixgbe and i40e's
> later. Not sure if it'll be counted as the ABI change if we change the ixgbe's
> name.
> 

A similar naming convention was used originally in the ethdev:
rte_eth_dev_set_vf_rxmode
rte_eth_dev_set_vf_rx
rte_eth_dev_set_vf_tx
rte_eth_dev_set_vf_vlan_filter
rte_eth_dev_set_vf_rate_limit

rte_eth_dev has just been replaced with rte_pmd_<ixgbe|i40e>

Regards,

Bernard.


More information about the dev mailing list