[dpdk-dev] [PATCH v8 1/5] lib/librte_ether: change function name of tunnel port config

Thomas Monjalon thomas.monjalon at 6wind.com
Wed Mar 9 10:48:55 CET 2016


2016-03-09 11:35, Wenzhuo Lu:
> +       uint16_t udp_port; /**< UDP port used for the tunnel. */
> +       uint8_t prot_type; /**< Tunnel type. */

Is 42 a valid tunnel type?
Please reference where to find the constants.
Think as a user who won't read your datasheet.

[...]
>   /**
> - * Add UDP tunneling port of an Ethernet device for filtering a specific
> - * tunneling packet by UDP port number.
> + * Add UDP tunneling port for a specific type of tunnel.
> + * The packets with this UDP port will be parsed as this type of tunnel.

We progress.
What will be parsed? What will be the action? checksum? decapsulation?

[...]
>  int
> +rte_eth_dev_udp_tunnel_port_add(uint8_t port_id,
> +                               struct rte_eth_udp_tunnel *tunnel_udp);
> +/* Below is deprecated. Replaced by rte_eth_dev_udp_tunnel_port_add. */
> +int
>  rte_eth_dev_udp_tunnel_add(uint8_t port_id,
>                            struct rte_eth_udp_tunnel *tunnel_udp);

Better. Please make a doxygen comment with @see.
We still need a __rte_deprecated attribute on the function.

> --- a/lib/librte_ether/rte_ether_version.map
> +++ b/lib/librte_ether/rte_ether_version.map
> @@ -117,3 +117,10 @@ DPDK_2.2 {
>  
>         local: *;
>  };
> +
> +DPDK_2.3 {
> +       global:
> +
> +       rte_eth_dev_udp_tunnel_port_add;
> +       rte_eth_dev_udp_tunnel_port_delete;
> +}DPDK_2.2;

Please rename 2.3 to 16.04. 




More information about the dev mailing list