[dpdk-dev] [PATCH v6 1/2] kni: add bulk function to free mbufs
olivier.matz at 6wind.com
Mon Jan 23 14:19:37 CET 2017
[resent and updated, previous mail was sent from the wrong address]
On Mon, 23 Jan 2017 13:59:47 +0100, Olivier Matz
<olivier.matz at 6wind.com> wrote:
> > + * @param mbufs
> > + * The packets mbufs array to be freed.
> > + * @param n
> > + * Number of packets.
> > + */
> > +static inline void rte_pktmbuf_free_bulk(struct rte_mbuf **mbufs,
> > + unsigned int n)
> I suggest we could use mbuf instead of pktmbuf in the function name.
> It's a bit shorter, and the function would also apply on ctrlmbuf.
Sorry, please ignore this one. It's more consistent to have a
rte_pktmbuf_free and rte_pktmbuf_free_bulk having the same prefix.
Also a small comment on the title: it should be "mbuf:", not "kni:".
In the other patch, the uppercase in "Use" could also be changed to
lowercase (seen with ./devtools/check-git-log.sh).
More information about the dev