[dpdk-dev] [PATCH] eal: added new `rte_lcore_is_service_lcore` API.

Van Haaren, Harry harry.van.haaren at intel.com
Wed Sep 20 16:53:04 CEST 2017


> From: Pavan Nikhilesh Bhagavatula [mailto:pbhagavatula at caviumnetworks.com]
> Sent: Friday, September 15, 2017 6:38 PM
> To: Thomas Monjalon <thomas at monjalon.net>
> Cc: Van Haaren, Harry <harry.van.haaren at intel.com>; dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH] eal: added new `rte_lcore_is_service_lcore`
> API.
> 
> On Fri, Sep 15, 2017 at 05:51:36PM +0200, Thomas Monjalon wrote:
> > 15/09/2017 16:59, Pavan Nikhilesh Bhagavatula:
> > > On Fri, Sep 15, 2017 at 02:44:57PM +0000, Van Haaren, Harry wrote:
> >
> > > > > > > We could also choose to add this function to rte_service.h ?
> > > > > >
> > > > > > Yes that is an option, and OK with me.
> > > > > >
> > > > > > @Pavan what do you think of adding it to service.h, implement in .c
> and add
> > > > > to .map?
> > > > > >
> > > > >
> > > > > The ROLE_SERVICE/ROLE_RTE defines the role of a lcore so it made sense
> to put
> > > > > it in rte_lcore.h as lcore properties are accessed mostly through this
> header.
> > > > > I'm fine with adding it to service.h as suggested by Harry.
> > > > >
> > > > > -Pavan
> > > >
> > > > *as suggested by Thomas ;)
> > > >
> > > > Initially I thought it made more sense in lcore.h too, however the
> application
> > > > should only require knowing if core X is a service core if it cares about
> > > > services / service-cores, hence I'm fine with rte_service.h too.
> > > >
> > > > -Harry
> > > >
> > > Agreed, will spin up a v2.
> >
> > The most difficult is to find a good name for this function :)
> 
> If not rte_lcore_is_service_core then how about rte_lcore_is_role_service?
> But this would need a sibling api rte_lcore_is_role_rte (or a better one) which
> is satisfied by rte_lcore_is_enabled :(
> IMO when role was limited to RTE & OFF rte_lcore_is_enabled fits now with
> new role SERVICE it looks out of place cause even service lcores are
> "enabled".
> Modifying rte_lcore_is_enabled would be a huge task (API change) as it is used
> widely in many places.

Hey all,

I've been thinking a little, and adding the "is service core" functionality in the
rte_service_* namespace might be the wrong place. The function name certainly doesn't
roll off the tongue ( rte_service_lcore_has_service_role() ?? )

What if we add a new function to rte_lcore.h? The implementation could be in a
new file, rte_lcore.c, to avoid "static inline" in a control-path function.

In my eyes, this approach is the cleanest as it allows re-use of the same function
for various types, including SERVICE, RTE, OFF etc. 


/** Probes if the calling core has a specific role.
 * @retval 1 If the core has role matching the *role* passed in
 * @retval 0 If the core's role does not match *role* passed in
 */
int
rte_lcore_has_role(enum rte_lcore_role_t role);


Application code becomes pretty self-documenting:
if (rte_lcore_has_role(ROLE_SERVICE)) {
    // do something
}

Thoughts? -Harry



More information about the dev mailing list