[dpdk-dev] [PATCH v3 0/2] eal/x86: Optimize rte_smp_mb() and create a new test case for it

Konstantin Ananyev konstantin.ananyev at intel.com
Mon Jan 15 16:04:38 CET 2018


v3 changes:
  Address Thomas and Keith code-review comments:
 - for readability, use "barrier" instead of "mb" in function and file naming.
 - Use SPDX tag for license header.

v2 changes:
  Address Bruce code-review comments:
  - get rid of macros to simplify the code
  - add more comments to the test case

Konstantin Ananyev (2):
  test/test: introduce new test-case for rte_smp_mb()
  eal/x86: Use lock-prefixed instructions to reduce cost of rte_smp_mb()

 .../common/include/arch/x86/rte_atomic.h           |  44 +++-
 test/test/Makefile                                 |   1 +
 test/test/test_barrier.c                           | 286 +++++++++++++++++++++
 3 files changed, 329 insertions(+), 2 deletions(-)
 create mode 100644 test/test/test_barrier.c

-- 
2.13.6



More information about the dev mailing list