[dpdk-dev] [PATCH 10/12] net/hns3: rename Rx burst API

Min Hu (Connor) humin29 at huawei.com
Thu Apr 15 03:58:38 CEST 2021



在 2021/4/15 1:41, Ferruh Yigit 写道:
> On 4/13/2021 12:50 PM, Min Hu (Connor) wrote:
>> From: Chengwen Feng <fengchengwen at huawei.com>
>>
>> Currently, user could use runtime config "rx_func_hint=simple" to
>> select the hns3_recv_pkts API, but the API's name get from
>> rte_eth_rx_burst_mode_get is "Scalar" which has not reflected "simple".
>>
>> So this patch renames hns3_recv_pkts to hns3_recv_pkts_simple, and
>> also change it's name which gets from rte_eth_rx_burst_mode_get to
>> "Scalar Simple" to maintain conceptual consistency.
>>
>> Also changes the hns3_recv_scattered_pkts API's name which gets from
>> rte_eth_rx_burst_mode_get to "Scalar".
>>
>> Fixes: 521ab3e93361 ("net/hns3: add simple Rx path")
>> Cc: stable at dpdk.org
>>
>> Signed-off-by: Chengwen Feng <fengchengwen at huawei.com>
>> Signed-off-by: Min Hu (Connor) <humin29 at huawei.com>
> 
> <...>
> 
>> @@ -2743,10 +2745,10 @@ hns3_rx_burst_mode_get(struct rte_eth_dev 
>> *dev, __rte_unused uint16_t queue_id,
>>           eth_rx_burst_t pkt_burst;
>>           const char *info;
>>       } burst_infos[] = {
>> -        { hns3_recv_pkts,        "Scalar" },
>> -        { hns3_recv_scattered_pkts,    "Scalar Scattered" },
>> -        { hns3_recv_pkts_vec,        "Vector Neon" },
>> -        { hns3_recv_pkts_vec_sve,    "Vector Sve" },
>> +        { hns3_recv_pkts_simple,    "Scalar Simple" },
>> +        { hns3_recv_scattered_pkts,    "Scalar"        },
>> +        { hns3_recv_pkts_vec,        "Vector Neon"   },
>> +        { hns3_recv_pkts_vec_sve,    "Vector Sve"    },
> 
> No concern on the burst function rename, that is driver internal, but 
> related to the above change, I think new value "Scalar Simple" is not 
> clear, what does 'Simple' mean?
> At least previously "Scalar Scattered" vs "Scalar" was more clear, one 
> can easily say difference is scattered Rx support, but with "Scalar" vs 
> "Scalar Simple" the difference is not clear.
> 
Agreed to retain the hns3_recv_scattered_pkts name "Scalar Scattered",
but suggests changing the hns3_recv_pkts_simple name to "Scalar Simple"
for the following reasons:
1. Currently, the transmit and receive algorithms implemented in C language
only process single-BD algorithms. The Rx direction is Scalar, while the
Tx direction is Scalar Simple. The two do not correspond with each other.
2. The algorithm name selected by using rx_func_hint=simple does not contain
simple. The DPDK user may be confused.

BTW, v2 has been sent, please check it out, thanks.
> .


More information about the dev mailing list