[PATCH v3 1/3] ethdev: rename action modify field data structure

Ferruh Yigit ferruh.yigit at amd.com
Tue Jan 30 18:19:07 CET 2024


On 1/15/2024 9:13 AM, Suanming Mou wrote:
> Current rte_flow_action_modify_data struct describes the pkt
> field perfectly and is used only in action.
> 
> It is planned to be used for item as well. This commit renames
> it to "rte_flow_field_data" making it compatible to be used by item.
> 

ack to rename struct to use in pattern.

> Signed-off-by: Suanming Mou <suanmingm at nvidia.com>
> Acked-by: Ori Kam <orika at nvidia.com>
> Acked-by: Andrew Rybchenko <andrew.rybchenko at oktetlabs.ru>
> ---
>  app/test-pmd/cmdline_flow.c            |  2 +-
>  doc/guides/prog_guide/rte_flow.rst     |  2 +-
>  doc/guides/rel_notes/release_24_03.rst |  1 +
>  drivers/net/mlx5/mlx5_flow.c           |  4 ++--
>  drivers/net/mlx5/mlx5_flow.h           |  6 +++---
>  drivers/net/mlx5/mlx5_flow_dv.c        | 10 +++++-----
>  lib/ethdev/rte_flow.h                  |  8 ++++----
>  7 files changed, 17 insertions(+), 16 deletions(-)
> 
> diff --git a/app/test-pmd/cmdline_flow.c b/app/test-pmd/cmdline_flow.c
> index ce71818705..3725e955c7 100644
> --- a/app/test-pmd/cmdline_flow.c
> +++ b/app/test-pmd/cmdline_flow.c
> @@ -740,7 +740,7 @@ enum index {
>  #define ITEM_RAW_SIZE \
>  	(sizeof(struct rte_flow_item_raw) + ITEM_RAW_PATTERN_SIZE)
>  
> -/** Maximum size for external pattern in struct rte_flow_action_modify_data. */
> +/** Maximum size for external pattern in struct rte_flow_field_data. */
>  #define ACTION_MODIFY_PATTERN_SIZE 32
>  

What do you think to update 'ACTION_MODIFY_PATTERN_SIZE' here too,
instead of next patch?

<...>

> diff --git a/lib/ethdev/rte_flow.h b/lib/ethdev/rte_flow.h
> index affdc8121b..40f6dcaacd 100644
> --- a/lib/ethdev/rte_flow.h
> +++ b/lib/ethdev/rte_flow.h
> @@ -3910,9 +3910,9 @@ enum rte_flow_field_id {
>   * @warning
>   * @b EXPERIMENTAL: this structure may change without prior notice
>   *
> - * Field description for MODIFY_FIELD action.
> + * Field description for packet field.
>

New note is not very helpful, how can we make it more useful?

Does it make sense to keep 'MODIFY_FIELD' and add 'COMPARE ITEM' in next
patch, to clarify the intended usage for the struct, otherwise it is too
generic.



More information about the dev mailing list